Compare commits

...

2 Commits

1 changed files with 13 additions and 0 deletions

13
tg-update-notify Normal file
View File

@ -0,0 +1,13 @@
## Check for update
/system package update
set channel=stable
check-for-updates
## Wait on slow connections
:delay 5s;
## Important note: "installed-version" was "current-version" on older Router OSes
:if ([get installed-version] != [get latest-version]) do={
## New version of RouterOS available, let's upgrade
/tool fetch url=("https://api.telegram.org/".$botID."/sendMessage\?chat_id=-***************&text=New version $[/system package update get latest-version] of RouterOS available, let's upgrade") src-address=***.***.***.* keep-result=no;
} else={
:log info ("No RouterOS upgrade found, checking this later...")
}